désynchronisation audio/vidéo pour les chaines HD

Des bugs, où ça ?
Répondre
Curtis
Messages : 164
Enregistré le : 27 févr. 2010, 20:15
Carte Tuner : Leadtek DTV1800H
Êtes-vous un robot ? : Je ne suis pas un robot

désynchronisation audio/vidéo pour les chaines HD

Message par Curtis » 07 août 2011, 20:36

Bonjour,

j'ai remarqué un bug très aléatoire ( donc difficile à reproduire ) dans pouchintvmod concernant les chaines HD :

parfois lors d'un zapping sur une chaine HD il peut se produire une très legère désynchronisation audio/vidéo, le son peut alors être en retard de 100 à 250 millisecondes par rapport à l'image,

en fermant et en relançant pouchintvmod cette désynchronisation disparait,

c'est un bug assez rare ( qui ne se produit peut-être que chez moi avec ma carte tuner et les codecs que j'utilise ),

la configuration:

- windows xp pro sp3 32 bits
- carte tuner leadtek DTV1800H
- carte vidéo ati radeon HD4650
- processeur pentium dual core 3.33 Ghz
- carte son integrée realtek HD audio
- codec vidéo et audio mpeg2 : powerdvd 10 ( cyberlink )
- codec vidéo h264: powerdvd 10 ( cyberlink )
- codec audio EAC3: ffdshow révision 3562 septembre 2010

est-ce qu'actuellement la synchronisation audio/vidéo dans pouchintvmod est garantie à 100% ? ( des lignes de code qui vérifieraient périodiquement la synchronisation audio/vidéo ou bien cela est sans objet compte tenu du fait qu'il y a des briques logicielles avec directshow et les codecs qui font la majeure partie du boulot d'affichage et du rendu audio ? )

il y a peut-être des histoires de tampon ou de buffer audio qui peuvent être surchargés et occasionner parfois une legère désynchronisation quand on zappe ou quand on relance le graph directshow ?

à noter que je n'ai pas de soucis avec les chaines SD, ce problème ne se produit qu'avec les chaines HD

Répondre