Pouchin TV Mod 0.5.194.1: Amélioration graphe + molette

Archive des versions expérimentales 0.5 (+ 0.4.173 et 0.6.0.216 RC) qui ont précédé la sortie de la version 0.6.0, ainsi que des discussions qui les concernent.
Avatar du membre
Gingko
Administrateur du site et développeur
Messages : 1958
Enregistré le : 05 août 2007, 12:57
Carte Tuner : (champ trop court pour énumérer 8 tuners)
Êtes-vous un robot ? : Je ne suis pas un robot
Localisation : Pantin (IDF, 93)
Contact :

Re: Pouchin TV Mod 0.5.194.1: Amélioration graphe + molette

Message par Gingko » 12 juil. 2009, 14:08

JL38 a écrit :La réinstallation du driver n'a rien changé. C'est comme mon problème avec ma Leadtek dtv1000s sous XP, c'est incompréhensible et ça en devient gavant.
A croire que j'ai pas de chance avec les tuners tnt...
En tout cas, c'est pas très grave, je sais que si j'ai besoin de faire un scan, je repasse sur la 188 et le tour est joué. On verra à la prochaine version si ça le fait toujours.

Encore merci pour cette réactivité !
Je crois que j'ai finalement trouvé la cause du problème.

À la révision 189, j'ai ajouté un test des messages d'erreur renvoyés par le tuner au changement de fréquence, avec annulation pour cette fréquence si un code d'erreur était retourné.
Auparavant, ce code n'était pas testé, ce qui était, selon moi, une lacune (d'autant plus que je souhaitais avoir ce code pour essayer de comprendre les problèmes rencontrés par d'autres).

Je pense que votre tuner renvoie ce code d'erreur (et qu'il l'a toujours renvoyé), mais qu'en dépit du code retourné, il sélectionne la fréquence correctement, donc ça marchait quand même dans les versions précédentes.

À l'appui de cette théorie, j'ajouterai que le code en question est testé pendant le recherche de chaînes, mais ne l'est toujours pas au changement de chaîne "normal".

Il va donc falloir que, sur réception de ce code d'erreur, je renvoie le message dans le log, mais que je n'arrête pas la recherche pour autant …

(ou alors demander à LeadTek qu'ils sortent une mise à jour de leur pilote qui sache sélectionner une fréquence sans renvoyer de code d'erreur intempestif)

Gingko
Gingko
․ ․ ․ ․ ․ ․ ․ ․ ․ ․ ․ ․ ․ ․ ․ ․ ․ ․ ․ ․ ․ ․ ․ ․ ․ ․ ․ ․ ․ ․ ․ ․ ․
Tuners utilisés, sur 3 ordis : • USB : AverMedia HDTV DVB-T Volar (2×) • PCI : Hauppauge Nova-DT Dual DVB-T • Express Card : AverMedia Digi Express 54

Avatar du membre
Gingko
Administrateur du site et développeur
Messages : 1958
Enregistré le : 05 août 2007, 12:57
Carte Tuner : (champ trop court pour énumérer 8 tuners)
Êtes-vous un robot ? : Je ne suis pas un robot
Localisation : Pantin (IDF, 93)
Contact :

Re: Pouchin TV Mod 0.5.194.1: Amélioration graphe + molette

Message par Gingko » 12 juil. 2009, 14:26

herszk a écrit :
herszk a écrit :Bonjour.
J'ai l'habitude de pointer le répertoire de captures vers une clé usb afin de pouvoir voir mes enregistrements sur ma freebox.
Le problème est que ma clé n'est pas toujours connectée à mon pc et quand je lance PTVM, j'ai un message qui m'indique que le répertoire n'existe pas et je perds le lien.
Serait-il possible que le test d'existence du répertoire soit lancé lorsqu'on accède à l'onglet capture plutôt qu'au démarrage du programme et que l'on ait la possibilité de connecter la clé à la volée sans être obligé de repasser par la case configuration/captures, ceci pour les distraits finis de mon espèce.

Je n'ai pas reçu de réponse à ce sujet, qu'en pensez-vous ?
Bonjour,

J'en pense surtout que si je fais ça, on risque d'amener une situation récurrente dans laquelle le programme va tenter d'effectuer des enregistrements dans un répertoire qui n'existe pas (si la clé n'est toujours pas insérée au moment de l'enregistrement).

Je vais réfléchir à une solution, mais il n'est pas du tout évident que ce sera celle-là.

Peut-être ajouter des boutons dans la boîte de message pour laisser à l'utilisateur le choix d'ignorer l'erreur.

Gingko

P.S.: de toutes façons, j'ai tendance à penser que faire l'enregistrement directement sur une clé USB n'est pas vraiment une chose à recommander ...
Gingko
․ ․ ․ ․ ․ ․ ․ ․ ․ ․ ․ ․ ․ ․ ․ ․ ․ ․ ․ ․ ․ ․ ․ ․ ․ ․ ․ ․ ․ ․ ․ ․ ․
Tuners utilisés, sur 3 ordis : • USB : AverMedia HDTV DVB-T Volar (2×) • PCI : Hauppauge Nova-DT Dual DVB-T • Express Card : AverMedia Digi Express 54

herszk
Messages : 39
Enregistré le : 11 nov. 2007, 18:22

Re: Pouchin TV Mod 0.5.194.1: Amélioration graphe + molette

Message par herszk » 12 juil. 2009, 18:31

Gingko a écrit :Peut-être ajouter des boutons dans la boîte de message pour laisser à l'utilisateur le choix d'ignorer l'erreur.


Non, je ne pense pas qu'il faille ignorer l'erreur mais juste donner la possibilité de rattraper un oubli , c'est-à-dire, rester sur un message de montage jusqu'à ce que le lien soit établi.
Pinnacle PCTV nano stick ultimate
Windows 7 64 familiale premium
ATI Radeon HD 3200 512 Mo partagés
AMD Athlon 64 X2 6000+ 3,1GHz

lukoluk
Messages : 28
Enregistré le : 09 nov. 2008, 21:41

Re: Pouchin TV Mod 0.5.194.1: Amélioration graphe + molette

Message par lukoluk » 13 juil. 2009, 21:41

Gingko a écrit :
lukoluk a écrit :Merci pour la réponse rapide,
j'utilise 2 comptes : un compte administrateur et un compte utilisateur (droits limités)
j'ai effectivement retrouver dans appdata du compte administrateur un répertoire pouchin tv mod que j'ai effacé
j'ai réinstallé 194.1 dans le compte administrateur et après config avec params par défaut (scan complet) le phénomène persiste !!
l'icone de FR3 est toujours absente !
le démarrage est maintenant OK
Lukoluk
idem quand je passe au compte utilisateur

Est-ce que l'icône se trouve bien dans le dossier "Icônes", au moins ?
Dans votre liste de chaînes, la chaîne est-elle nommée "FR3" ou bien "France 3" ?
(sachant que, dans tous les cas de figure, l'icône doit avoir exactement le même nom que la chaîne)

Gingko


Exact
dans le fichier "icones" le nom du fichier est "France 3" dans la liste des chaines de PTVM le nom est "France3" sans espace
après correction du nom dans le fichier icones ça fonctionne.
Néanmoins, pourquoi France3 sans espace alors que France 2 France 5 et France 4 sont avec espace ?
Je suis peut-être perfectionniste !!
Merci pour la qualité de fonctionnement de PTVM
Lukoluk
Loc : entre DOUAI et CAMBRAI (59)
Réception TNT : Lille-Bouvignies (62) - RTBF Tournai - VRT Egem
Décodeurs : SAGEM HD (TNTOP) - Philips DTR220 - Worldsat DT2T
PC : AMD Turion 64X2 TL-50 1Go NVIDIA Go 7600 XP SP3
clé USB AVERMEDIA A828 / PouchinTV 0.4-130

Avatar du membre
Gingko
Administrateur du site et développeur
Messages : 1958
Enregistré le : 05 août 2007, 12:57
Carte Tuner : (champ trop court pour énumérer 8 tuners)
Êtes-vous un robot ? : Je ne suis pas un robot
Localisation : Pantin (IDF, 93)
Contact :

Re: Pouchin TV Mod 0.5.194.1: Amélioration graphe + molette

Message par Gingko » 13 juil. 2009, 22:14

lukoluk a écrit :Exact
dans le fichier "icones" le nom du fichier est "France 3" dans la liste des chaines de PTVM le nom est "France3" sans espace
après correction du nom dans le fichier icones ça fonctionne.
Néanmoins, pourquoi France3 sans espace alors que France 2 France 5 et France 4 sont avec espace ?
Les noms de chaînes sont diffusés dans le multiplex, dans l'émission elle-même.

Normalement, France 3 est diffusée comme les autres chaînes, avec espace (c'est comme ça chez moi), mais il est tout-à-fait possible que certaines déclinaisons régionales spécifient le nom sans espace, ce qui est une erreur de leur part.
Pour compenser ça, on peut éventuellement ajouter une autre icône pour France3 sans espace, en espérant ne pas retrouver ce problème trop souvent avec d'autres chaînes.

Gingko
Gingko
․ ․ ․ ․ ․ ․ ․ ․ ․ ․ ․ ․ ․ ․ ․ ․ ․ ․ ․ ․ ․ ․ ․ ․ ․ ․ ․ ․ ․ ․ ․ ․ ․
Tuners utilisés, sur 3 ordis : • USB : AverMedia HDTV DVB-T Volar (2×) • PCI : Hauppauge Nova-DT Dual DVB-T • Express Card : AverMedia Digi Express 54

lukoluk
Messages : 28
Enregistré le : 09 nov. 2008, 21:41

Re: Pouchin TV Mod 0.5.194.1: Amélioration graphe + molette

Message par lukoluk » 13 juil. 2009, 23:51

Gingko a écrit :
lukoluk a écrit :Exact
dans le fichier "icones" le nom du fichier est "France 3" dans la liste des chaines de PTVM le nom est "France3" sans espace
après correction du nom dans le fichier icones ça fonctionne.
Néanmoins, pourquoi France3 sans espace alors que France 2 France 5 et France 4 sont avec espace ?
Les noms de chaînes sont diffusés dans le multiplex, dans l'émission elle-même.

Normalement, France 3 est diffusée comme les autres chaînes, avec espace (c'est comme ça chez moi), mais il est tout-à-fait possible que certaines déclinaisons régionales spécifient le nom sans espace, ce qui est une erreur de leur part.
Pour compenser ça, on peut éventuellement ajouter une autre icône pour France3 sans espace, en espérant ne pas retrouver ce problème trop souvent avec d'autres chaînes.

Gingko


OK, si France Télévision ne respecte pas la "codification" des noms de chaines, vous n'y pouvez rien et ce n'est pas à vous mais à France 3 que je devrais faire ma remarque !

Je capte actuellement les chaines sur l'émetteur de Perpignan Pic de Néoulous, je n'ai effectivement pas ce problème sur l'émetteur de Lille Bouvigny !
Bien cordialement,
Lukoluk
Loc : entre DOUAI et CAMBRAI (59)
Réception TNT : Lille-Bouvignies (62) - RTBF Tournai - VRT Egem
Décodeurs : SAGEM HD (TNTOP) - Philips DTR220 - Worldsat DT2T
PC : AMD Turion 64X2 TL-50 1Go NVIDIA Go 7600 XP SP3
clé USB AVERMEDIA A828 / PouchinTV 0.4-130

Avatar du membre
Gingko
Administrateur du site et développeur
Messages : 1958
Enregistré le : 05 août 2007, 12:57
Carte Tuner : (champ trop court pour énumérer 8 tuners)
Êtes-vous un robot ? : Je ne suis pas un robot
Localisation : Pantin (IDF, 93)
Contact :

Re: Pouchin TV Mod 0.5.194.1: Amélioration graphe + molette

Message par Gingko » 13 juil. 2009, 23:58

lukoluk a écrit :OK, si France Télévision ne respecte pas la "codification" des noms de chaines, vous n'y pouvez rien et ce n'est pas à vous mais à France 3 que je devrais faire ma remarque !

Ils ne sont probablement même pas obligés de le faire. Ça ne dérange pas les décodeurs TNT classiques, en général, et les applications qui essaient d'associer une icône au nom de leur chaîne doivent être assez anecdotiques, de leur point de vue. :)

Gingko
Gingko
․ ․ ․ ․ ․ ․ ․ ․ ․ ․ ․ ․ ․ ․ ․ ․ ․ ․ ․ ․ ․ ․ ․ ․ ․ ․ ․ ․ ․ ․ ․ ․ ․
Tuners utilisés, sur 3 ordis : • USB : AverMedia HDTV DVB-T Volar (2×) • PCI : Hauppauge Nova-DT Dual DVB-T • Express Card : AverMedia Digi Express 54

jean019
Messages : 45
Enregistré le : 13 janv. 2008, 23:54

Re: Pouchin TV Mod 0.5.194.1: Amélioration graphe + molette

Message par jean019 » 18 juil. 2009, 23:28

bon, ca marche avec leadtek, comme d'hab :)
peut être un son de temps en temps haché, mais je pense que cela provient plutôt de mon pc.
Leadtek PCI DTV1000S + ATI HD4550 + Windows 7 64bits (Hauppauge HVR1300 en backup)

Avatar du membre
Gingko
Administrateur du site et développeur
Messages : 1958
Enregistré le : 05 août 2007, 12:57
Carte Tuner : (champ trop court pour énumérer 8 tuners)
Êtes-vous un robot ? : Je ne suis pas un robot
Localisation : Pantin (IDF, 93)
Contact :

Re: Pouchin TV Mod 0.5.194.1: Amélioration graphe + molette

Message par Gingko » 19 juil. 2009, 02:14

jean019 a écrit :bon, ca marche avec leadtek, comme d'hab :)
peut être un son de temps en temps haché, mais je pense que cela provient plutôt de mon pc.
Bonjour,

C'est quel genre de PC ?
(il se trouve que j'ai un problème analogue avec un des miens …)

Gingko
Gingko
․ ․ ․ ․ ․ ․ ․ ․ ․ ․ ․ ․ ․ ․ ․ ․ ․ ․ ․ ․ ․ ․ ․ ․ ․ ․ ․ ․ ․ ․ ․ ․ ․
Tuners utilisés, sur 3 ordis : • USB : AverMedia HDTV DVB-T Volar (2×) • PCI : Hauppauge Nova-DT Dual DVB-T • Express Card : AverMedia Digi Express 54

fabien59
Messages : 135
Enregistré le : 06 mai 2007, 06:45
Carte Tuner : Nano Stick 73e , P7131 Dual

Re: Pouchin TV Mod 0.5.194.1: Amélioration graphe + molette

Message par fabien59 » 23 juil. 2009, 15:53

Bonjour,

un scan ne trouve pas les chaines HD ... je dois toujours creer mon fichier de chaines .xml manuellement.

j'ai un problème avec le canal 59 avec Virgin 17 I Télé etc ...

ca se caractérise par des décrochages réguliers ...

je n'ai pas ce problème sur dvbviewer ...

+ le problème au lancement de pouchin TV des chaines TNT de certains multiplex qui ne se lancent pas, il faut recliquer sur la chaine pour que ca fonctionne..


Merci
Asus MyCinema P7131 Dual OK
2 x Pinnacle Nanostick 73e OK
PouchinTV Mod HD OK

JL38
Messages : 179
Enregistré le : 25 févr. 2009, 21:24

Re: Pouchin TV Mod 0.5.194.1: Amélioration graphe + molette

Message par JL38 » 23 juil. 2009, 16:22

+ le problème au lancement de pouchin TV des chaines TNT de certains multiplex qui ne se lancent pas, il faut recliquer sur la chaine pour que ca fonctionne..

Je constate également ce petit problème, pas d'image et de son au démarrage, obligation de recharger la chaine. Mais c'est apparemment pas systématique.
Et puis l'histoire du son haché, ça me le fait avec le codec Cyberlink PowerDVD8 seulement. Avec ffdshow ou ArcSoft, pas de soucis.

Verrouillé