Bugs en pagaille suite au passage au tout HD

Pour toutes les questions sur le fonctionnement de Pouchin TV Mod auxquelles vous n'avez pas trouvé de réponse dans la documentation.
Commodore75
Messages : 9
Enregistré le : 05 avr. 2016, 13:39
Carte Tuner : Hauppauge WinTV NOVA TD HD dual tuner Stick USB
Êtes-vous un robot ? : Je ne suis pas un robot

Re: Bugs en pagaille suite au passage au tout HD

Message par Commodore75 » 07 avr. 2016, 18:51

Gingko a écrit : Une réinstallation de certains composants pourrait se révéler nécessaire.
J'ai tout désinstallé (logiciel et codecs), nettoyé, et réinstallé uniquement Pouchin TV Mod et LAV Filters 0.68. Ça ne fonctionne toujours pas. Mêmes messages d'erreur que ceux cités dans un précédent message.

J'ai renouvelé l'opération, et là je n'ai installé que Pouchin TV Mod et ffdshow. Cela parait fonctionner correctement, mais j'ai toujours les problèmes de zapping et de plantage sur certaines chaînes. Je crois que je vais rester comme ça et m'accommoder de ses bugs, bon gré mal gré... :(

Visiblement, personne n'a trouvé de solutions. Merci quand même !!

Avatar du membre
Gingko
Administrateur du site et développeur
Messages : 1959
Enregistré le : 05 août 2007, 12:57
Carte Tuner : (champ trop court pour énumérer 8 tuners)
Êtes-vous un robot ? : Je ne suis pas un robot
Localisation : Pantin (IDF, 93)
Contact :

Re: Bugs en pagaille suite au passage au tout HD

Message par Gingko » 07 avr. 2016, 18:56

gaw a écrit :J’ai trouvé, dans les sources, les (petites) modifications à faire : il faut, en effet forcer le changement de codec vidéo à chaque changement de chaine.
Ça marche bien avec ffdshow.
Par contre, cette version de pouchintv (0.6.2.295) ne marche pas (ou mal) avec LAV. Gingko, aurais-tu les sources de la version 0.6.3.352 ?
Dans le référentiel Subversion.

Normalement à récupérer avec un logiciel tel que Subversion ou TortoiseSVN.

Voir la page de compilation pour davantage d'informations.

Gingko
Gingko
․ ․ ․ ․ ․ ․ ․ ․ ․ ․ ․ ․ ․ ․ ․ ․ ․ ․ ․ ․ ․ ․ ․ ․ ․ ․ ․ ․ ․ ․ ․ ․ ․
Tuners utilisés, sur 3 ordis : • USB : AverMedia HDTV DVB-T Volar (2×) • PCI : Hauppauge Nova-DT Dual DVB-T • Express Card : AverMedia Digi Express 54

Commodore75
Messages : 9
Enregistré le : 05 avr. 2016, 13:39
Carte Tuner : Hauppauge WinTV NOVA TD HD dual tuner Stick USB
Êtes-vous un robot ? : Je ne suis pas un robot

Re: Bugs en pagaille suite au passage au tout HD

Message par Commodore75 » 07 avr. 2016, 19:06

Tiki a écrit :Bonjour,
j'ai le meme probleme et c'est aparement bien en relation avec les differentes resolutions SD, HD, FULL HD. Chez moi probleme avec SD et HD soit les chaines 3, 5, 6, 7, 9, 19, 22, 26. Un article explicatif interressant:
http://www.telesatellite.com/actu/47055 ... abais.html
Je confirme les numéros de chaînes, c'est quasiment les mêmes pour moi.

Merci pour cet article très intéressant. C'est bien ce que je craignais, ce passage au tout HD n'a pas amélioré la qualité des images pour toutes les chaînes, au contraire. Certaines ont même régressé, c'est honteux, surtout quand on pense que bon nombre de Français ont du être obligé de se rééquiper pour pouvoir recevoir cette pseudo TNT HD, c'est scandaleux !!

Commodore75
Messages : 9
Enregistré le : 05 avr. 2016, 13:39
Carte Tuner : Hauppauge WinTV NOVA TD HD dual tuner Stick USB
Êtes-vous un robot ? : Je ne suis pas un robot

Re: Bugs en pagaille suite au passage au tout HD

Message par Commodore75 » 07 avr. 2016, 19:12

gaw a écrit : Par contre, cette version de pouchintv (0.6.2.295) ne marche pas (ou mal) avec LAV. Gingko, aurais-tu les sources de la version 0.6.3.352 ?
Sur cette page, vous pouvez trouver un lien permettant de télécharger Pouchin TV Mod 0.6.3.352 ;) http://www.pouchintv.fr/forum/viewtopic.php?f=11&t=1233

Avatar du membre
Gingko
Administrateur du site et développeur
Messages : 1959
Enregistré le : 05 août 2007, 12:57
Carte Tuner : (champ trop court pour énumérer 8 tuners)
Êtes-vous un robot ? : Je ne suis pas un robot
Localisation : Pantin (IDF, 93)
Contact :

Re: Bugs en pagaille suite au passage au tout HD

Message par Gingko » 07 avr. 2016, 19:25

Commodore75 a écrit :Sur cette page, vous pouvez trouver un lien permettant de télécharger Pouchin TV Mod 0.6.3.352 ;) http://www.pouchintv.fr/forum/viewtopic.php?f=11&t=1233
Il parlait du code source, je crois.

Gingko
Gingko
․ ․ ․ ․ ․ ․ ․ ․ ․ ․ ․ ․ ․ ․ ․ ․ ․ ․ ․ ․ ․ ․ ․ ․ ․ ․ ․ ․ ․ ․ ․ ․ ․
Tuners utilisés, sur 3 ordis : • USB : AverMedia HDTV DVB-T Volar (2×) • PCI : Hauppauge Nova-DT Dual DVB-T • Express Card : AverMedia Digi Express 54

jeanaimarre
Messages : 6
Enregistré le : 07 avr. 2016, 00:47
Carte Tuner : Avermedia Volar Green HD
Êtes-vous un robot ? : Je ne suis pas un robot

Re: Bugs en pagaille suite au passage au tout HD

Message par jeanaimarre » 07 avr. 2016, 19:40

Ce qui se passe chez moi
=====================
- Toutes les chaines HD sont bien détectées et figurent dans la liste.
- 3 ensembles de chaines sur lesquelles on peut zapper séparément :
Groupe 1 - France 3 / France 5 / M6 / Arte / W9 / France 4 HD / France O / 6Ter / LCI
Groupe 2 - TF1HD / France 2 HD / D8 / TMC / NT1 / NRJ12 / LCP / BFMTV / I>Télé / D17 / Gulli / HD1 / L'Equipe 21 / Numero 23 / RMC Découverte / Chérie 25 / TV7 Bordeaux
Groupe 3 - LCI

Problème
========
Quand on est sur un des groupes et qu'on veut passer à une chaîne d'un autre groupe, on obtient uniquement le son.

Solution de dépannage
===================
Pour obtenir l'image de ce groupe de chaine, il suffit de :
- Se positionner sur la chaîne
- Quitter PouchinTV Mod
- Relancer Pouchin TVMod

Il suffirait donc peut-être de faire une RàZ de toutes les variables à chaque changement de chaîne

Avatar du membre
Gingko
Administrateur du site et développeur
Messages : 1959
Enregistré le : 05 août 2007, 12:57
Carte Tuner : (champ trop court pour énumérer 8 tuners)
Êtes-vous un robot ? : Je ne suis pas un robot
Localisation : Pantin (IDF, 93)
Contact :

Re: Bugs en pagaille suite au passage au tout HD

Message par Gingko » 07 avr. 2016, 20:03

jeanaimarre a écrit :Ce qui se passe chez moi
=====================
- Toutes les chaines HD sont bien détectées et figurent dans la liste.
- 3 ensembles de chaines sur lesquelles on peut zapper séparément :
Groupe 1 - France 3 / France 5 / M6 / Arte / W9 / France 4 HD / France O / 6Ter / LCI
Groupe 2 - TF1HD / France 2 HD / D8 / TMC / NT1 / NRJ12 / LCP / BFMTV / I>Télé / D17 / Gulli / HD1 / L'Equipe 21 / Numero 23 / RMC Découverte / Chérie 25 / TV7 Bordeaux
Groupe 3 - LCI

Problème
========
Quand on est sur un des groupes et qu'on veut passer à une chaîne d'un autre groupe, on obtient uniquement le son.

Solution de dépannage
===================
Pour obtenir l'image de ce groupe de chaine, il suffit de :
- Se positionner sur la chaîne
- Quitter PouchinTV Mod
- Relancer Pouchin TVMod

Il suffirait donc peut-être de faire une RàZ de toutes les variables à chaque changement de chaîne
Il n'y a pas de variable qui soit susceptible d'être réinitialisée à chaque changement de chaîne.

Le problème c'est plutôt la réponse respective de chacun des filtres DirectShow (ce qui inclut les tuners, le démultiplexeur, les codecs et les filtres de rendu) quand on leur demande de s'arrêter et de se remettre en route.

Chacun de ces filtres est susceptible de gérer un ou plusieurs fils d'exécution (« threads ») concurrents, et leur bon fonctionnement dépend souvent de la qualité de conception de chaque filtre, s'ils ne sont pas bien conçus, on peut avoir des phénomènes de blocages ou bien de « deadlocks » (quand un fil ou un processus attend quelque chose du fil voisin alors que le fil voisin attend lui aussi quelque chose du fil qui attend quelque chose de lui).

Pouchin TV Mod n'inclut presqu'aucun filtre de sa propre conception, il délègue généralement ces tâches à des filtres externes, soit fournis dans les bibliothèques de Windows (démultiplexage et rendu), soit fournis par des prestataires ou vendeurs externes (codecs et gestion des tuners via leurs pilotes).

Assurez-vous donc déjà d'avoir les meilleures versions possibles de ces codecs et des pilotes de vos tuners.

Gingko
Gingko
․ ․ ․ ․ ․ ․ ․ ․ ․ ․ ․ ․ ․ ․ ․ ․ ․ ․ ․ ․ ․ ․ ․ ․ ․ ․ ․ ․ ․ ․ ․ ․ ․
Tuners utilisés, sur 3 ordis : • USB : AverMedia HDTV DVB-T Volar (2×) • PCI : Hauppauge Nova-DT Dual DVB-T • Express Card : AverMedia Digi Express 54

gaw
Messages : 3
Enregistré le : 05 avr. 2016, 20:09
Carte Tuner : Pinnacle PCTV 713x Tuner BDA DVBT Tuner
Êtes-vous un robot ? : Je ne suis pas un robot

Re: Bugs en pagaille suite au passage au tout HD

Message par gaw » 07 avr. 2016, 20:41

Gingko, je te remercie, j’ai téléchargé la version 0.6.3.352 via svn.
J’ai modifié les sources, compilé, ça marche bien, sans bug, pour l’instant, avec ffdshow et LAV.
Je ne vous propose pas ces modifications pour l’instant pour plusieurs raisons : c’est fait « à la sauvage », je teste juste la version « debug » et je ne connais l’environnement de développement (visual C++ 2008) que depuis quelques heures.

lysdis
Messages : 5
Enregistré le : 05 avr. 2016, 12:58
Carte Tuner : Clé USB Savvy Intuix S800 / Driver LiteOn
Êtes-vous un robot ? : Je ne suis pas un robot

Re: Bugs en pagaille suite au passage au tout HD

Message par lysdis » 07 avr. 2016, 22:26

Je viens de découvrir l'existence de la version 0.6.3.352 grâce à ton message gaw.
Elle n'est pas sur la page principale des téléchargements mais dans le forum des versions expérimentales, du coup j'avais toujours une "ancienne" version qui ne fonctionne pas avec les LAVfilters ! (messages d'erreurs)

La version 0.6.3.352 par contre fonctionne avec les LAVfilters et je n'ai plus les bugs d'écrans noirs au changement de chaines !!
Problème résolu pour moi ! \o/

mekp
Messages : 14
Enregistré le : 20 juin 2010, 15:06
Carte Tuner : pinnacle PCTV hybrid pro pci
Êtes-vous un robot ? : Je ne suis pas un robot

Re: Bugs en pagaille suite au passage au tout HD

Message par mekp » 08 avr. 2016, 10:38

Après avoir enregistré toutes les chaines en .ts , j'ai constaté que les formats étaient :

- 1920x1080 pour :
1 : TF1 , 2 : France 2 HD , F3 Paris Ile-de-France HD , 4 : CANAL+ , 8 : D8 , 10 : TMC , 11 : NT1 ,
12 : NRJ12 , 13 : LCP , 15 : BFM TV , 16 : i>TELE , 17 : D17 , 18 : Gulli , 20 : HD1 , 21 : L'Equipe 21
23 : NUMERO 23 , 24 : RMC Découverte , 25 : Chérie 25 , 30 : BFM Business Paris HD

- 1440x1080 pour :
5 : France 4 HD , 6 : M6 , 9 : W9 , 14 : France 5 , 19 : France O HD , 22 : 6ter , 57 : Arte

- 720x576 pour :
26 : LCI , 41 : PARIS PREMIERE , 31 : Canal 31 , 32 : IDF1 , 33 : France 24

- ????x???? pour 34 : Canal 34

J'ai également constaté (avec ffmpeg) que l'affichage de la vidéo redevenait correct
en désactivant puis réactivant le rendu vidéo

Je suis également en train d'essayer de faire une modification dans les sources ... A SUIVRE ...

PS :
Si 'gaw' pouvait proposer ses (petites) modifications à faire pour forcer le changement de codec vidéo
à chaque changement de chaine , ça serait sympa ...
NOTA : à "chaque changement de format" plutôt qu'à "chaque changement de chaine" serait mieux
toutefois le fichier chaines.xml ne fournit pas les formats

tchup
Messages : 6
Enregistré le : 06 avr. 2016, 12:13
Carte Tuner : Clé AVerTV Hybrid Volar HX
Êtes-vous un robot ? : Je ne suis pas un robot

Re: Bugs en pagaille suite au passage au tout HD

Message par tchup » 08 avr. 2016, 15:52

jeanaimarre a écrit :Ce qui se passe chez moi

Solution de dépannage
===================
Pour obtenir l'image de ce groupe de chaine, il suffit de :
- Se positionner sur la chaîne
- Quitter PouchinTV Mod
- Relancer Pouchin TVMod

Il suffirait donc peut-être de faire une RàZ de toutes les variables à chaque changement de chaîne
Une solution plus rapide que j'utilisais avant d'installer le codec LAV filters :
- Se positionner sur la chaîne
- Redémarrer le graphe (CTRL + Q par défaut)
lysdis a écrit : Je viens de découvrir l'existence de la version 0.6.3.352 grâce à ton message gaw.
Elle n'est pas sur la page principale des téléchargements mais dans le forum des versions expérimentales, du coup j'avais toujours une "ancienne" version qui ne fonctionne pas avec les LAVfilters ! (messages d'erreurs)

La version 0.6.3.352 par contre fonctionne avec les LAVfilters et je n'ai plus les bugs d'écrans noirs au changement de chaines !!
Problème résolu pour moi ! \o/
Je ne suis pas chez moi pour vérifier, mais je crois que j'ai également cette dernière version expérimentale 0.6.3.352, et le LAV filters fonctionne sans problème.
C'est peut être bien la solution pour ceux qui ont des soucis de configuration des codecs.

jeanaimarre
Messages : 6
Enregistré le : 07 avr. 2016, 00:47
Carte Tuner : Avermedia Volar Green HD
Êtes-vous un robot ? : Je ne suis pas un robot

Re: Bugs en pagaille suite au passage au tout HD

Message par jeanaimarre » 08 avr. 2016, 18:29

Un grand merci à tous ceux qui ont trouvé la solution de la version 0.6.3.352 avec les LAVfilters
Cà fonctionne pour moi. Super

lysdis
Messages : 5
Enregistré le : 05 avr. 2016, 12:58
Carte Tuner : Clé USB Savvy Intuix S800 / Driver LiteOn
Êtes-vous un robot ? : Je ne suis pas un robot

Re: Bugs en pagaille suite au passage au tout HD

Message par lysdis » 08 avr. 2016, 21:05

Les LAVfilters fonctionnent mais il y a des artefacts de compression au changement de chaine qui ne dure que quelques secondes, mais aussi des clicks et craquements en audio de temps en temps.
Du coup j'ai essayé les Codecs Microsoft DTV et là aussi ça passe avec cette version, et bien mieux que LAV.
Du coup j'ai tout mis en Microsoft et les changements de chaine et le son sont propres.

jeanaimarre
Messages : 6
Enregistré le : 07 avr. 2016, 00:47
Carte Tuner : Avermedia Volar Green HD
Êtes-vous un robot ? : Je ne suis pas un robot

Re: Bugs en pagaille suite au passage au tout HD

Message par jeanaimarre » 09 avr. 2016, 00:38

Oui, je confirme les pixels et craquements, mais c'est vraiment minime...

Brunolacompile
Messages : 10
Enregistré le : 16 févr. 2013, 14:05
Carte Tuner : Terratec cinergy T2 Hauppage nova t usb2 pcTV nanostick ultimate plus
Êtes-vous un robot ? : Je ne suis pas un robot

Re: Bugs en pagaille suite au passage au tout HD

Message par Brunolacompile » 09 avr. 2016, 15:45

Ma configuration : XP 32, LAV filters pour la vidéo, ffdshow pour l'audio. Carte graphique nvidia GTX 750. Pouchin TV Mod en rendu vidéo EVR.

J'ai cru moi aussi trouver "la" solution en passant à la version 0.6.3.352.
Mais en même temps, j'avais aussi réinstallé les LAV filters, et en réalité, c'est cela qui a fait la différence, pas la montée en version du logiciel Pouchin, je l'ai vérifié par la suite.

En effet, ce qui a vraiment résolu chez moi le problème des passages entre chaînes HD de diverses résolutions, c'est le retour à "None" dans la case "Hardware decoder to use" dans le panneau de configuration vidéo des LAV Filters (au lieu de "nvidia cuvid").
C'est la configuration par défaut à l'installation des LAV filters...
Evidemment, c'est une "solution" très insatisfaisante quand on dispose d'un GPU capable de faire le boulot pour le décodage vidéo, mais même comme cela, les LAV filters ne chargent pas plus le CPU que ffdshow.

------------------------------------------------------------------------------------------------------------------------------------
Par ailleurs, sur une autre configuration : Seven 64, MS codec pour la vidéo, ffdshow pour l'audio, carte graphique nvidia G210M. Pouchin TV Mod 64 bit en rendu vidéo EVR2. CPU Intel core duo (obsolète mais largement suffisant) :
aucun problème après passage au tout HD, avec la version standard de Pouchin TV mod 64 bit.

.....Ce qui tend à prouver que les problèmes proviennent des codecs et autres logiciels autour de Pouchin, plutôt que de Pouchin TV Mod lui-même. Espérons cependant qu'une modification dans notre logiciel préféré permettra de le "blinder" contre les errements de son environnement. Donc merci par avance à gaw.
Modifié en dernier par Brunolacompile le 12 avr. 2016, 15:21, modifié 7 fois.

Répondre